Jump to content
Chris John Willett

cna't play halo 4 campaign past the intro vid

Recommended Posts

so i decided recently to do a legendary run of the halo 4 campaign as i was getting bored of play non-stop halo 4 multiplayer but it jumps me back to the menu when the intro cutscene is finished. i tried loading the first level manually but it says i don't have the required download or something like that. i have completed the campaign multiple times,i treid backing up the disk to my hardrive but it stoped, i have an xbox 360S, i have tried turning it off and on again, the disc has hardly any scratch but i cleaned it anyway, the second disc has been downloaded and i put that disc back in anyway. i just don't get it, campaign worked perfectly fine now suddenly it does not work? and i really don't want to start everything all over again, i have played too much multiplayer to start over 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...

×
×
  • Create New...